Back to overview
Degraded

Game Site

Oct 02 at 04:07am EDT
Affected services
Game Hosting

Resolved
Oct 02 at 12:25pm EDT

Everything is now running fine

Created
Oct 02 at 04:07am EDT

Game website degraded